Een zeer handige Excel formule is SOM.ALS. In het Engels de SUMIF formule. De SOM.ALS formule wordt gebruikt om getallen in een kolom bij elkaar op te tellen wanneer in een andere kolom aan een specifieke voorwaarde wordt voldaan.

Ik heb een voorbeeld gemaakt waarin verschillende fruitsoorten –en rassen zijn opgenomen en de daarbij behorende jaaromzet.

Het is eenvoudig om de totale omzet te bepalen door middel van de SOM functie. Om te beginnen bepalen we de totale omzet in cel C14.

=SOM(C2:C13)

Het totaal van deze formule is EUR 99.200

SOM.ALS formule in de praktijk

Maar wanneer we nu alleen het totaal van de appels willen weten gebruiken we de SOM.ALS formule. In cel C14 zetten we de volgende formule.

=SOM.ALS(A2:A13;”Appels”;C2:C13)

Deze formule bestaat feitelijk uit drie delen

  • In A2:13 wordt het bereik bepaald waaraan aan een bepaalde voorwaarde voldaan moet worden
  • In “Appels” zetten we criterium waaraan in het bereik aan voldaan moet worden. In dit geval “Appels”.
  • In C2:C13 wordt alle getallen opgeteld mits deze voldoen aan het criterium “Appels” in het voorwaarden bereik

Het resultaat is in dit geval EUR 34.000

Wanneer we in cel C15 en C16 nu de totale omzet van de peren resp. mandarijnen willen bepalen gebruiken we de volgende formules

CEL C15 =SOM.ALS(A2:A13;”Peren”;C2:C13)
CEL C16 =SOM.ALS(A2:A13;”Mandarijnen”;C2:C13)

De SOM.ALS formule met een absolute verwijzing

Het kan heel handig zijn om in de SOM.ALS formule niet te werken met vaste waarden zoals “Appels”, “Peren” of “Mandarijnen” maar met een dynamische selectie. Er wordt een totaal berekend op basis van de selectie afhankelijk van de waarde die we invoeren. Het volgende voorbeeld laat zien hoe dit werkt.

We zetten in cel C17 de volgende formule:

=SOM.ALS(A2:A13;$A$17;C2:C13)

In feite is deze formule identiek aan de formules zoals in de vorige voorbeelden zijn gebruikt. In plaats van vaste waarden als bijvoorbeeld “Appels” gebruiken we nu echter een absolute verwijzing naar A17.

Wanneer we nu in veld A17 “Mandarijnen” invullen verschijnt dynamisch het totaal van de mandarijnen. Indien we vervolgens in dit zelfde veld “Peren” invoeren wordt de totale jaaromzet van Peren bepaald

Zie ook het voorbeeldbestand SOMALS

Je hebt nu leren werken met de SOM.ALS (SUMIF) formule. Succes met excelleren.

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *

Deze website gebruikt Akismet om spam te verminderen. Bekijk hoe je reactie-gegevens worden verwerkt.